HaxeFlixel and OpenFl 4

Today after a very long time, I opened haxe again in the hopes of making a small game.

Updated all the libraries using haxelib upgrade.

But when I tried running my HaxeFlixel project. I found that Flixel is not yet compatible with the latest version of OpenFl.
Flixel is currently incompatible with OpenFL 4.0.0. Please use version 3.6.1 or older.
Flixel is currently incompatible with Lime 3.0.0. Please use version 2.9.1 or older.

So, in the Project.xml I set these settings, in the hopes that it would work.

But, Alas! It failed to compile and gave me a new error!

Scratching my head, I looked it up on Google, but to my utter horror could find no solution.

In the end I had to rollback my version of openfl and lime for the time being. And I set them back to the required versions using HaxeLib.

That worked 😀

Now back to GameDev!

Author: Gautam

I am a Human, MOOCer, Harmonica Enthusiast, Budding Polyglot and an Indie Game Developer. I develop apps and games for fun and profit. Wherever and whenever you see me, I am sure to have my harp in my pocket. Maybe if you say please I will play you a tune.